QuickBooks Database Manager Conflicts with DNS Server

Modified on Thu, 28 Apr, 2022 at 5:31 AM

This is an ongoing bug with the way that QuickBooks runs on most windows servers that are also running DNS Server service.

This applies to all versions up to and including 2020

Here’s a fix I discovered for a problem when running QuickBooks  2016 and DNS on a Windows 2012 server.

Symptoms:

  • Users get the error Error Code: H202 This company file is on another computer, and QuickBooks needs some help connecting.
  • QuickBooks  server manager service on the Windows 2012 server is not running.
  • When you run the QuickBooks Database Server Manager, and click Start Scan, it scans the folders, then get an error: QuickBooks  network diagnostics failed. Resolve errors and retry.
  • If you try to start the QuickBooksDB26 system service, it starts and then immediately stops, giving the message, “The QuickBooksDB26 service on Local Computer started and then stopped.  Some services stop automatically if they are not in use by other services or programs.”
  • In the Application log on the server this error appears:”The description for Event ID 1 from source SQLANY 16.0 cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

Cause:

In my case, the QuickBooks  database server, and DNS server are both using port 55333. If DNS is running first, quickbooks doesn’t choose another available port, but rather stops completely.

Quick Solution:

- Stop the DNS Server service, then start the QuickBooks  service.

This works, but you will have the same problem after a reboot.

Permanent workaround:

- Stop the DNS Server service, and the Quickbooks service.
- Reserve the port using netsh from the command prompt
- netsh int ipv4 add excludedportrange protocol=udp startport=55368 numberofports=5
- then start both services

See more info on the netsh command related to this.

More details on the quickbooks forums related to this same problem here.

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